Webmin Installation

Webmin installation is quite straightforward. However, the webmin packages that most how-to articles are telling users to use are static versions that become outdated.
This can throw errors of the following kind:

Note, selecting 'webmin' instead of './webmin_1.900_all.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

A simple solution is to pull the latest mirror link and use apt to pick all dependencies (since apt is dpkg anyway):

Debian: wget https://www.webmin.com/download/deb/webmin-current.deb
RedHat: wget https://www.webmin.com/download/rpm/webmin-current.rpm
Source: wget https://www.webmin.com/download/webmin-current.tar.gz

As a result, this will redirect wget to the latest Sourceforge release and allow you to perform installation as per usual (debian stretch as an example):

apt install ./webmin-current.deb

Congratulations, we’re done here!

Webmin install complete. You can now login to https://abc.xyz:10000/

Leave a Reply

Your email address will not be published.